
Tulsa Public Schools:  Promethean – Module 3 Page 1 of 11 5/23/2008 

Promethean Training 
Module 3 

 
 
 
The pages of a Flipchart consist of layers.  They are like transparent sheets which contain only certain types of objects 
unless you move objects from one layer to another. 
 
Top Layer 
Contains all annotations (pen, highlighter, and eraser) objects.  These objects will display on top of any other object placed 
on the 2 layers below. 
Middle Layer 
Contains the following object types: 

• Image 
• Line 
• Shape 
• Text 

Anything written and converted to text with the Hand Recognition Tool will be placed on the middle layer also.  
Bottom Layer 
Initially empty until you physically place something on it. 
Background Layer 
The background layer consists of 3 elements: 

• Background page color 
• Background image 
• Grid 

If the background image is smaller than the page size, the image will be automatically tiled to fill the page.   
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Section 1:  Understanding Layers 
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Objects are added to the appropriate layer in the order that they are added with the 
most recent on the top. 
 
Example 
Shapes reside on the middle layer.  So any shape you place on the Flipchart page will automatically be placed on the 
middle layer. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Changing the Order WITHIN a Layer 
In the sample below, the textbox is in FRONT of the image.  This means that the textbox was added AFTER the image was 
placed on the page.  If you want the textbox BEHIND the image, you will have to change the order.  The order will be 
changed within this layer and not between layers.  To change the order of objects WITHIN a layer, right click one of the 
objects and this will bring up the Quick Select Toolbox.   Go to Edit then you will select To Front or To Back, depending 
on the position desired for the selected object.  Note:  You can also use the Object Edit Toolbox icons. 
 
 

   
 

 
 
 
 
 
 
 
 
 

 

Section 2:  Object Stacking Order 
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Changing the Layer of an Object 
  
 
 
 
Right click on the object and the Quick 
Select Toolbox will appear.  Left click 
on the M to activate the drop-down 
menu.   Edit > Layer > Bottom, Middle, 
or Top. 
 
You have the option to 
move objects to any of the 4 
layers. 
 
 
 
 
 
 
 
 
 
Clearing a Layer 
 
The Clear Tool allows you to clear items layer by layer.  You will just have to know what is on each layer.  If you 
accidentally clear something, you can use the Undo to restore. 
 

 
 
 
 
 
 
 
 
 

 
 
 
 
 

Section 3:  Changing and Clearing 
Layers 
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The Eraser Tool does not physically remove the annotation or the object placed on the Top Layer.  It adds a transparent 
layer on top of any object on the Top layer, which allows the objects on the Middle, Bottom or Background Layer to show 
through.  The Eraser object can be selected with the Marquee Select tool and moved like any other object—allowing for 
creative ways to discover or reveal items on your Flipchart. 
 
Example: 
• From the Resource Library, add a sleeping boy to your page and then add a house.  (The house will be on top of the boy 

because of the order that you added them to the page.)  Images always reside on the Middle Layer until you change the 
layer. 

• Move the house to the Top Layer. 
• Move and resize the house so that it totally covers the sleeping boy. 
• Choose the Eraser Tool and erase the house.  You will see it will be erased while the sleeping boy remains. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
VERY IMPORTANT:  In the Design Mode, the default is to allow locked objects to 
move.  Go to the Main Menu > Studio Settings > Design Mode to review the default 
settings. 
 
To lock an image to make it immovable in the PRESENTATION MODE, look at the image of the drop-down box in Section 2 
above.  You find the lock option in the Quick Select Toolbox.  Edit > Lock/Unlock. 
 
To Lock Image to the Background:   
Quick Select Toolbox > Edit > Layer > Lock on Background 
Once items are locked on the background, you will not be able to select, edit, or view the properties for the object.  Multiple 
objects can be locked to the background at once but selecting all of them then go through Lock on Background steps 
above. 

Section 4:  The Eraser Tool in 
Layers 

Section 5:  Locking and Unlocking 
Objects 
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To Unlock the Items on the Background: 
First, at least one object has to be locked on the background.  If not, you 
won’t get the option to unlock.  To unlock, Right click on page, from Quick 
Select Toolbox, Main Menu > Unlock All Background Objects. 
 
 
 
 
 
 
 
 
 
You have many existing teaching resources (PowerPoint, Word, Excel, favorite websites, CDs of textbook resources, etc.) 
—you don’t have to convert them all to Flipcharts.  Anything you can access with your computer can be shown on the 
ActivBoard.  You have the ability to use the ActivStudio tools within other teaching resources. 
 
When you activate the Annotate over Desktop button, two different functions may occur depending on your Studio 
Settings. 
THERE ARE 2 TYPES OF DESKTOP FLIPCHARTS: 
 

1. Page Background is a live desktop.  With this setting, a transparent layer is placed over the desktop.  You can use 
all of ActivStudio’s tools in this mode.  The Marquee Select Tool interacts with your desktop through the transparent 
layer.  When saving the Desktop Flipchart in this mode, only the annotations will be saved but NOT the Desktop.  
This is the default setting for WIN 2000/XP, and later versions. 

 
You will see indicators which demonstrate there is a Flipchart on top of the application you are working in.  Upper 
left corner, you will see the name and page of the Flipchart.  Upper right corner, more symbols.   You will also see a 
black frame that indicates there is a flipchart page on top of the Desktop. 

 
 

  
 To add a page to the Flipchart, use the arrow key in the Flipchart Toolstrip.  To save the Flipchart, click on 

the floppy disk icon in the Flipchart Toolstrip. 
 

Section 6:  ActivStudio with Other 
Applications 
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2. Page Background is a photo of the desktop.  TO GET INTO THIS MODE, YOU HAVE TO GO TO Menu > Studio 

Settings > Desktop Flipchart (on left side of pop-up box) > select “Annotate on a picture of the desktop.”  
This type of Desktop Flipchart is an inactive image of your desktop.  ActivStudio will take a picture, or screen shot, 
of whatever is on your desktop.  All of ActivStudio‘s tools can be used on this type of Desktop Flipchart.  When you 
save this Desktop flipchart, the whole Flipchart, including the desktop image, will be saved.  NOTE:  The live 
desktop will not be visible, so you cannot click on links, etc. 

 
 
 
 
 
You can customize the User Defined Buttons located on your Main Toolbar.  The shortcuts would be saved with the 
particular Flipchart you are working with.  You can shortcut to a website, file (such as PowerPoint), etc.  From the Main 
Toolbox, expand the width using the second arrow.  Once it is expanded, the arrow changes directions. 

 
There are 3 User Defined Buttons.   
 
Customize a User-Defined Button 
• Right click on the button 
• Choose Program File from the menu 
• Click Browse 
• Locate the document you wish to use 
• Click Open 

• The path to the file will be displayed in the dialog box.  Click OK. 
• The appropriate icon will appear on the Main Toolbox.  If you linked to an Excel File, the Excel icon will appear. 
• To define a website, type the URL in the Program line. 
• TO REMOVE A USER-DEFINED BUTTON, open the Toolstore and drag the button to the Toolstore.  It won’t be 

added to the Toolstore but will be removed form the Main Toolbox. 
• TO ADD ADDITIONAL USER-DEFINED BUTTONS, open Toolstore and you will find the icon in the Power Tools 

section. 
 
 
 
 
 
As you learned in Section 1 of this module, you have the ability to open 
other applications and use the ActivStudio tools within that application.  
You also have the option to take an existing PowerPoint file and import 
it into the Promethean software, thus converting the PowerPoint 
document into a Flipchart.  When you do this: 
 
• Each slide of the PowerPoint will be created as a background on 

the Flipchart Page 
• The slide becomes an image, and you will no longer have the ability 

to edit the content. 
• You will be able to use all the ActivStudio tools on the page. 
 
Conversion Process: 
Main Menu > Flipchart > Import > PPT Converter 

Section 7:  User Defined Buttons 

Section 8:  Converting PowerPoint 
to a Flipchart 
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The “Arrange Windows” feature allows you to copy/paste/drag & drop content from either one flipchart to another or from 
another application (such as the web) to a flipchart. 
 
VERY IMPORTANT!   

1. In the Design Mode, you access the “Windows Arranger” 
through the Menu Bar.  First the Menu Bar has to be 
activated.  To do this:  Main Menu > Customize > then select 
Menu Bar. 

 Once the Menu Bar is activated, select 
 Window > Arranger 
 

 
  
 
 
 

2. In the Presentation Mode, you will see the “A” in the upper 
right-hand corner of the screen.  Click on the “A” then 
“Arrange Windows…” 

 
 
 
 
 
 The following window will pop up.  This window allows you to determine the size of the flipchart you 
 working on.  You are now arranging the viewable documents on your computer screen. 
 

  

 The Arrange Windows box allows you to organize your currently open windows. Activstudio will organize the 
 following windows: 

• Flipcharts. 
• Resource Library, when it is docked. 
• Link Windows, when the Include Link Windows checkbox is selected. (covered in Module 4) 

 

 

Section 9:  Arrange Windows 
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If you want to bring in the content of digital material and maintain the ability to edit, you may copy the text and images to 
your Flipchart.  Material from the following can be copied and pasted into a Flipchart: 
• Word Documents 
• Information from Web Pages 
• PDF files 
• Resources on CD’s 
• PowerPoint Presentations 
• More 

 
Copy and Paste Steps: 
1. Open the document from which you want to 

copy material 
2. Use your cursor to select the area to copy – 

highlight the area 
3. Right click after highlighting the desired text 
4. Left click on Copy 
5. Right click on the Flipchart page where you 

want to place the copied material. 
6. The Quick Select Menu will appear. 
7. Click on the M to bring up Menu 
8. Edit > From Clipboard > Text 
9. The text font can be changed using Object Edit 

Toolbox procedures learned in Module 1. 
 
 
 
 
 
 
 
The same types of documents that can be copied and pasted from also have the drag and drop feature.   
 
Steps to Drag and Drop 
 
1. Open both document/website where you want to drag material from.  This could be from one flipchart to another.  

Below are 2 screen shot examples:  Flipchart to Flipchart and Website or Other Document to Flipchart 
 
 
 

 
 
 
 
 
 
 
 

Section 10:  Copy and Paste 
Material into a Flipchart 

Section 11:  Drag and Drop 
Material into a Flipchart 
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Flipchart to Flipchart 
• Drag the item to the new Flipchart 
• Select either “Copy Here” or “Move Here”  If you copy, the text will reappear on the Flipchart in the original location 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Website or Other Document to Flipchart 
These steps are a little different.  You will have to use 
the Window Arranger for the Flipchart.  Then in the other 
document where you want to drag material, you will 
have to click on the middle window resize button 

in the upper right-hand corner.  This enables 
you to see both documents at the same time.  You may 
have to manually arrange the second window so that 
you see the material to drag.  Then highlight the material 
to drag and drag to Flipchart.  
 
 
 
 
 
 
This is a useful tool for several teaching strategies.  If you copy and paste or drag and drop text from one location to 
another, it moves as a total text box.  If you want to pull a word out of the text box, right click on the word and the Quick 
Select Toolbox will appear.  From the Menu, select Deconstruct.  The word you right clicked on will be duplicated so that 
you can pull it out.  The word can be manipulated in any manner.  You can also add the word to the Text category of My 
Resources.  Covered in Module 5. 
 
 
 
 
 
 
The Camera Tool allows you to capture, as an image, anything displayed on your desktop.  The photograph becomes an 
image object you can add to your Flipchart page, Resource Library, or Clipboard, allowing you to manipulate it like any other 
object. 
 

Section 12:  Deconstruct 
Flipchart Text 

Section 13:  Using the Camera 
Tool 
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Steps in Using the Camera Tool: 
1. Open the document or website with the content you want to take a “picture” of. 
2. Open the ActivStudio software. 
3. On the Main Toolbox, click on the Hide the Desktop Flipchart icon.  This allows you to use the ActivStudio tools while 

working in other applications.  (Section 4 above) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
4. Click on the Camera Tool on the Main Toolbox. 
5. Once you click on the Camera Tool, you will have several options.  

You have 4 options of the size of picture you want.  Then you have 
options on where you want the picture to be placed. 
 
 
 
 

6. If you select Area, you will have to opportunity to draw a box around the desired area (using your mouse).  Experiment 
with the options of Point to Point, Freehand, and Window.  Also, once the Camera Tool is activated, the options of 
where the captured image is to be placed appears in a small toolbar. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Image to Capture 

Hide Desktop 
Flipchart 

Camera Tool 

Outline the image you 
want captured OR move 
and reshape the pop-up 
box that appears once you 
click on the Camera Tool. 

Hover over each icon to 
select the placed location 
of the captured image.  
Clicking on one of these 
options actually takes the 
picture. 
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Important Information 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
Images taken with the Camera Tool, objects in the Resource Library, or any annotation you may have completed can be 
placed on the Shortcut Toolbar on the Main Toolbar.  Placing items on the Shortcut Toolbar which you need easy access 
to assists in presentations as well as in developing Flipcharts. 
 
To Place an Item on the Shortcut Toolbar: 
 
1. The Item must first be on the Flipchart page. 
2. Roll out the Shortcut Toolbar on the Main Toolbar. 
3. Drag and drop the object you want onto the Shortcut Toolbar.  
 When you see the Hand icon in the Shortcut Toolbar, you may release the object.  
 
To Remove the Item from the Shortcut Toolbar 
1. Open the Toolstore 
2. Drag the item from the Shortcut Toolbar to the Toolstore. 

Section 14:  Add Resources to 
the Shortcut Toolbar 


